[anaconda+python] spyder 5.0.0 버전 열자마자 나오는 에러 메시지(You have missing dependencies! # Mandatory: spyder_kernels)에 관하여 2021.04.10 20:09:22
반응형

최근에 윈도우10 컴퓨터에 아나콘다(anaconda)와 스파이더(spyder)를 설치한 후 스파이더를 열어보니 어느덧 5.0.0버전의 스파이더가 나왔더군요. 제가 한창 스파이더를 많이 쓸 때는 3버전이었는데 말이죠.

 

그런데 스파이더 IDE가 열리자마자 다음과 같은 이상한 오류 메시지가 나와서, 다시 깔아야하나 순간 고민했습니다.

 

 

그래도 이 에러가 무엇인지 한 번 확인해봐야겠다 싶어서 구글링을 해봤습니다. 역시 스택오버플로에 답이 있더군요. 

 

stackoverflow.com/questions/66952832/spyder-5-missing-dependencies-spyder-kernels-version-error

 

Spyder 5 missing dependencies - spyder_kernels version error

Spyder gives me error message like above, but I cannot solve it. I think the version of spyder_kernels should be 2.0.1 at least, but I already updated my version as 2.0.1. Why I get such warning me...

stackoverflow.com

 

답변을 읽어보니 아무런 문제가 되지 않으니 걱정하지 않아도 된다는 것이었습니다. 스파이더 팀에서 공식적으로 답변을 단 것 같습니다. 이 에러 메시지는 그냥 무시해도 좋다고 합니다. 곧 5.0.1 버전에서 수정될 것이라고 합니다. 

 

찾아보지 않았더라면 번거롭게 삭제와 설치를 되풀이할 뻔 했습니다. 역시 검색을 잘해야 합니다. 

반응형
secret
-
+